Poggio is unavailable
Resolved·Full outage

The app is fully functional. Thanks for your patience.

Thu, Jun 12, 2025, 09:07 PM
(3 days ago)
·
Affected components
App
Updates

Resolved

The app is fully functional. Thanks for your patience.

Thu, Jun 12, 2025, 09:07 PM

Monitoring

Our cloud provider is continuing to fix the underlying cause of the outage. We are seeing most of the app’s functionality back online including account research and chat.

Thu, Jun 12, 2025, 08:51 PM(15 minutes earlier)

Monitoring

Our cloud provider is continuing to fix the underlying cause of the outage. We are seeing some of the apps functionality returning, but with degraded performance

Thu, Jun 12, 2025, 08:15 PM(35 minutes earlier)

Investigating

Our cloud provider has identified the root cause and is applying appropriate mitigations, app functionality is still degraded at this time.

Thu, Jun 12, 2025, 07:47 PM(28 minutes earlier)

Investigating

We are working to restore full functionality as our primary cloud provider services begin to recover.

Thu, Jun 12, 2025, 07:09 PM(38 minutes earlier)

Investigating

Investigating an issue with our primary cloud provider that is affecting ability of users to login.

Thu, Jun 12, 2025, 06:13 PM(55 minutes earlier)